Questions sur python-3.6

4
réponses

F-strings en Python 3.6

j'aime vraiment creuser dans le style de code et il est intéressant de savoir si à partir de maintenant dans tous les ... ns de rendement, y a-t-il une différence entre elles? Ou c'est juste une apparence simple de la même fonctionnalité?
demandé sur 2017-03-30 19:25:20
6
réponses

pip3 s'installe dans un environnement virtuel avec python3.6 échec dû au module ssl Non disponible

(py36venv) [email protected]:/vagrant/venvs$ pip3 install pep8 pip est configuré av ... qui satisfait à l'exigence pep8 (à partir des versions:) aucune correspondance distribution trouvée pour pep8
demandé sur 2017-01-05 19:00:54
2
réponses

Quelles sont les annotations variables en Python 3.6?

Python 3.6 est sur le point de sortir. PEP 494 -- Python 3.6 Release Schedule mentionne la fin du mois de décemb ... ère: Comment primes: List[int] = [] expliquer? Est-ce qu'il définit une liste vide qui permettra juste des entiers?
demandé sur 2016-10-11 10:00:15
6
réponses

Comment puis-je convertir un.py.exe pour Python?

j'essaie de convertir un programme Python assez simple en un exécutable et je n'ai pas trouvé ce que je cherchais, don ... que je vois ne fonctionnent que jusqu'à python 3.5 - dois-je télécharger et utiliser cette version si j'essaie cela?
demandé sur 2017-01-10 16:44:59
3
réponses

Les dictionnaires sont-ils commandés en Python 3.6+?

Les dictionnaires sont ordonnés en Python 3.6 (sous l'implémentation CPython au moins) contrairement aux précédentes i ... .) mise à jour décembre 2017: dict s l'ordre d'insertion de retenue est garanti pour Python 3.7
demandé sur 2016-10-11 17:59:23
5
réponses

Microsoft Windows Python-3.6 erreur D'installation de Phycrypto

pip install pycrypto fonctionne très bien avec python3.5.2 mais échoue avec python3.6 avec l'erreur suivante: inttypes.h(26): error C2061: erreur de syntaxe: identificateur 'intmax_t'
demandé sur 2017-01-25 07:14:26
4
réponses

Installez tkinter en python3.6 sur Ubuntu

+--------+-----------------------------------+ | OS | Ubuntu 12.04 | +--------+------------------ ... -linux-gnu.so de tcl / tk? Remarque : je n'ai tcl/tk est installé, que j'ai confirmé à l'aide de tclsh et le souhaitez.
demandé sur 2017-03-06 13:22:05